1 Visualization with OpenDX ............................................. 1
  1.1 OpenDX module installation ........................................ 1
     1.1.1 Compilation of OpenDX module ............................ 2
     1.1.2 Configuration of the startup script ......................... 2
  1.2 OpenDX Controls ..................................................... 3
  1.3 Visualization ....................................................... 4
     1.3.1 Visualizing molecular structures and graphs .............. 5
     1.3.2 Visualizing scalar properties ............................... 8
List of Tables
List of Figures

1.1 Accessing Control Panels in OpenDX Image Window ............... 3
1.2 Structure Control Panel ........................................... 5
1.3 OpenDX Image Window showing molecular structure, slice, isosurface and basin ...................................................... 6
1.4 Property Control Panel ............................................... 9
Chapter 1
Visualization with OpenDX

The visualization of DGrid generated data can also be performed with the freeware OpenDX program. Two main parts are responsible for this:

- an OpenDX module, providing routines which read DGrid file formats and extend its built-in modules. The module itself is a single binary file.

- an OpenDX visual program providing simple GUI for end user. The visual program is a text file which is read by OpenDX to create the necessary GUI and do proper visualization.

The OpenDX module installation is described in Sec. 1.1. Very short introduction into OpenDX controls is done in Sec. 1.2. The usage of the visual program is described in Sec. 1.3.

Detailed information about the visualization package OpenDX can be found in the Internet at http://www.opendx.org. In many Linux distributions (e.g., openSUSE) it is available via the software repositories (usually called opendx or dx) so one may easily install it using the package manager.

Although powerful enough, OpenDX is nowadays a bit outdated and not that flexible like, e.g., ParaView. The OpenDX visualisation module for DGrid is not planned to be developed further.

1.1 OpenDX module installation

An OpenDX module is made available as separate part of the DGrid package. There are 2 ways to deploy the module:

- Precompiled modules are available for x86-64 Linux or x86-32 Microsoft Windows versions of OpenDX. They were tested on x86-64 Linux openSUSE 11.3
and on x86-32 Microsoft Windows Vista Premium. These binary modules are not included in the DGrid package. Visit the DGrid website to download the modules.

- The module can be built from the source code provided with the DGrid. The so-called ‘devel’ version of OpenDX (with header files and libraries included) needs to be installed additionally to create the module from the source. The next Subsec. 1.1.1 describes how to built the module on the Linux machine.

### 1.1.1 Compilation of OpenDX module

Be sure that the ‘devel’ version of OpenDX is installed so that the OpenDX header files and libraries are available. Put the source files from the archive into:

```
dgrid-4.6/DXDGrid
```

and modify the `makefile` to specify the path to the OpenDX folder (BASE=). One might need to modify the target platform as well when it is not Linux and the C/C++ compiler to be used when it is not GNU. The module is built with the command:

```
make
```

The module binary file called `dxdgrid` should appear in the folder.

### 1.1.2 Configuration of the startup script

An OpenDX start script must be configured before starting OpenDX. This script called `startdxdgrid` sets up all necessary command line options for OpenDX so that the DGrid visual program can be executed.

The following files are used in the visualization of DGrid data with OpenDX:

- `startdxdgrid` or `startdxdgrid.bat` — launch script
- `dxdgrid`(Linux) or `dxdgrid.dll`(Windows) — module binary file
- `dxdgrid.mdf` — module description file
- `dxdgrid.net` — visual program file
- `dxdgrid.cfg` — visual program configuration file
- `ELF.mk.cm` — classical ELF colormap
1.2 OpenDX Controls

All these files can be found in dgrid-4.6/DXDGrid folder (when the module is built from the sources) or in the distribution archive (for precompiled modules).

Following locations must be set up in startdxdgrid script:

- OpenDX installation path (BASE=)
- DGrid module file dxdgrid path (DXMODULES=)
- Module description file dgrid.mdf path (MDF_PATH=)
- Visual program file dgrid.net path (NET_PATH=)

It is recommended to add the location of the start script to the user PATH environment variable.

Now OpenDX is ready for the DGrid format. To test it prepare some property grid (for instance the electron density grid for oxazole given in the DGrid User’s Guide).

1.2 OpenDX Controls

The DGrid-specific controls of visualization program are implemented as so called control panels. There are four control panels – two for structure-like data (‘Structure-I’ and ‘Structure-II’) i.e. molecular structures or interconnection paths and two for scalar property data, e.g., charge density or ELI-D basins (‘Property-I’ and ‘Property-II’). They can be opened from the main menu of ‘Image Window’ using (cf. Fig. 1.1):

Windows → Open Control Panel by Name

General controls of OpenDX are accessible through other menu options (cf. Fig. 1.1). Most important among them are:

- File → Save Image or File → Print Image — to save the image.
- Execute → Execute on Change — to activate on-the-fly visualization

Fig. 1.1 Accessing Control Panels in OpenDX Image Window
• \textbf{Execute} \rightarrow \textbf{Execute Once} — to update the picture manually when on-the-fly visualization is too slow.
• \textbf{Execute} \rightarrow \textbf{End Execution} — to abort the visualization when it takes too much time.
• \textbf{Windows} \rightarrow \textbf{Open All Colormap Editors} — to open colormap editor used for coloring of the slices.
• \textbf{Windows} \rightarrow \textbf{Open Message Window} — to open diagnostic message window.
• \textbf{Options} \rightarrow \textbf{View Control} — to select some visualization options like the use of perspective.
• \textbf{Options} \rightarrow \textbf{Mode} — to select mouse behavior like rotate or zoom.
• \textbf{Options} \rightarrow \textbf{Reset} — to reset the view.
• \textbf{Options} \rightarrow \textbf{Set Background Color} — self explanatory.
• \textbf{Options} \rightarrow \textbf{Rendering options} — to select rendering options. Whenever possible, choose the hardware rendering.

Detailed information about all these menu items can be found in Chapter 8, \textit{Graphical User Interface: Menus, Options, and the Message Window of OpenDX User's Guide}.

1.3 Visualization

1. Start OpenDX by typing the name of the start script \textit{startdxdgrid}.

2. In the Image Window activate on-the-fly visualization mode by clicking \textbf{Execute} \rightarrow \textbf{Execute on Change} (cf. Sec. 1.2)

If on-the-fly visualization is too slow due to heavy data set, do not select this menu. Instead, each time the picture is modified and need to be redrawn, select \textbf{Execute} \rightarrow \textbf{Execute Once} or press \textit{Ctrl-O} key combination to update the drawing.
1.3 Visualization

1.3.1 Visualizing molecular structures and graphs

1.3.1.1 Load

1. Open the Structure-I control panel. (cf. Sec. 1.2)

2. Press the button to open a file selector box (cf. Fig. 1.2).

3. Select the grid or STR file to be loaded (e.g., C3H3NO_HF_6-31G.g03.rho,r).

   If on-the-fly visualization was enabled, remark that ‘Execute’ menu item lights green for certain time indicating the OpenDX is processing the data.

4. To show the structure on the screen activate ‘Show Structure’ checkbox in the ‘Structure-I’ menu (cf. Fig. 1.2). Select Execute → Execute Once or press Ctrl-O key combination to update the drawing, if on-the-fly visualization was
disabled. The structure will appear on the screen as a ball-and-stick model (cf. Fig. 1.3).

Remark 1.1. In the DGrid property file certain atoms could be marked as invisible (e.g. those outside the box selected for property calculations) However the DX module ignores the atom visibility and always plots all the atoms. If one wants to omit the invisible atoms from the visualization, one can comment them out in the property file.

1.3.1.2 Navigate

- To **rotate** the structure, go to **Options → Mode** menu of the Image Window (cf. Sec. 1.2) and select **Rotate** item. Alternatively, **Ctrl-R** key combination can be pressed. Then the structure can be rotated with the left or right mouse button pressed.

- To select the area to be **zoomed** go to **Options → Mode** and select **Pan/Zoom** item. Alternatively **Ctrl-G** (under Windows: **Ctrl-Space**) combination can be
1.3 Visualization

pressed. Then the structure can be zoomed/unzoomed by selecting the proper area with the left or right mouse button pressed.

1.3.1.3 Modify

- To modify the atom properties, select it from the dropdown list ‘Atom to modify’ (cf. Fig. 1.2), set up new color and radius and press [Apply]. Atom labels can also be shown to identify the atoms. To do this, activate ‘Show Labels’ checkbox and adjust label size. The label size is the same for all the atoms.

\textit{Remark 1.2}. Please pay attention that both the color (color coordinates must be in the range from -0.999999 to 0.999999) and radius of the atom will be set to the values from that control panel even if they were not touched.

- To modify the connections drawn, select the connection partner atoms from the dropdown lists \texttt{Atom1} and \texttt{Atom2} (cf. Fig. 1.2), set up allowed distance range and press [Apply].

The color and diameter of connections can be modified as well. To modify them, just set up new values. The color and diameter are the same for all the connections.

1.3.1.4 Some remarks to the visualization of critical points and interconnection paths

To visualize the interconnection paths first the file with the data for the critical points and the path points, written in the STR format, must be read in. After the file is read the graph can be visualized the same way as in case of the molecular structure data, cf. page 5. In contrast to the atomic data, now the ‘Atom to modify’ list does not contain atomic symbols but the symbols for the critical points (and cores), i.e., \texttt{Attr}, \texttt{Saddle}, \texttt{Ring}, \texttt{Min}, respectively \texttt{Core}.

- For the molecular graphs the CPs are treated like atoms. One may modify their color and size and plot the labels. For different CPs of the same type (i.e. attractors \texttt{Attr}_1 and \texttt{Attr}_2) it is not possible to set different colors or radii, these parameters are always the same for all the CPs of certain type.

- One may control the visualization of interconnection lines between critical points via ‘Connection Parameters’ controls. To hide certain interconnection line, set maximal distance to zero and press [Apply]. To visualize certain interconnection line, select the line endpoint CPs and set minimal distance to zero and maximal distance to any nonzero number and press [Apply]. By default all the interconnection lines are visualized. It is not possible to set up a straight connection line
between the CPs, they can have a connection only if the interconnection path was found by DGrid and written into STR file. The color and diameter are the same for all the interconnection lines.

1.3.1.5 Loading second structure file

The Structure-II control panel (cf. Sec. 1.2) allows to load a second structure with either molecular structure or CPs and interconnection paths (e.g., C3H3NO_HF.6-31G.g03.rho_rbsn.graph.str) in addition to the structure loaded with the ‘Structure-I’ control panel. This can be useful for the comparison between two diagrams or for plotting CP graph and molecular structure in the same time. The ‘Structure-II’ control panel has the same controls as ‘Structure-I’.

1.3.2 Visualizing scalar properties

1. Open the Property-I control panel (cf. Sec. 1.2).

2. If grid file (e.g., C3H3NO_HF.6-31G.g03.rho_r) is already loaded with ‘Structure-I’ control page, one can activate the checkbox ‘Use Property from Structure-I’ to visualize the charge density field from this grid file (cf. Fig. 1.4). Alternatively, the button of the ‘Read Property from’ field may be pressed and the desired grid file selected.

3. To visualize the slice of the scalar property, specify at least one non-zero normal to the slice plane in the ‘Slice normals’ (cf. Fig. 1.4). To modify the normal, select it from the list and set new normal components using the number controls below the list. In the same way one may modify the coordinates of the point on the slice plane in the right ‘Slice points’ list. Finally activate the ‘Show slices and colorbar’ checkbox to show slices on the screen (cf. Fig. 1.3). Arbitrary many slices can be plot at the same time using Add button.

To select another colormap or modify current colormap used by slices open the menu Window → Open All Colormap Editors (cf. Sec. 1.2). Detailed information about Colormap Editor can be found in Subsection 8.1 Colormap Menu Bar of OpenDX User’s Guide.

Remark 1.3. The ‘holes’ that can appear on the slice marks the regions where the scalar property value is outside of the colormap value range.

4. To plot the isosurface of the scalar property, specify at least one isosurface value in the ‘Isosurface values’ list (cf. Fig. 1.4). To modify the isosurface
value, select it from the list and set new value using the control below the list. In the right window one specifies the isosurface colors. To modify the color select it with the mouse in the ‘Isosurface colors’ list and then modify the color coordinates. When no color is specified for certain isosurface, the default color will be used. Finally activate the ‘Show isosurfaces’ checkbox to show isosurfaces on the screen (cf. Fig. 1.3). Arbitrary many isosurfaces can be plot at the same time using **Add** button.

- If the *basin* file containing a field of integer values showing basin number of each grid point is read, the **basins** can be visualized as separate solid objects. To visualize the **basins**, specify at least one basin number in the ‘Basin numbers’ list (cf. Fig. 1.4). To modify the basin number, select it from the list
and set new number using the control below the list. In the right window one specifies the basin colors. To modify the color select it with the mouse in the ‘Basin colors’ list and then modify the color coordinates. When no color is specified for certain basin, the default color will be used. Finally activate the ‘Show basins’ checkbox to show basins on the screen (cf. Fig. 1.3). Arbitrary many basins can be plot at the same time using Add button.

1.3.2.1 Loading second property file

The ‘Property-II’ control panel (cf. Sec. 1.2) allows to load a second scalar property (e.g., C3H3NO_HF_6-31G,g03.elid it) in addition to the property loaded with the ‘Property-I’ control panel. The ‘Property-II’ control panel has the same controls as ‘Property-I’.

1.3.2.2 Some remarks to the properties plots

- All the color coordinates must be in the range from -0.999999 to 0.999999

- The ‘Show bounding box’ checkbox can be activated to show the bounding box of the region inside which the scalar property was calculated (cf. Fig. 1.4).

  Remark 1.4. This box is correct only for orthogonal grids. For non-orthogonal grids it shows orthogonal region which is larger than real region of the property calculated.

- Any added slice, isosurface or the basin can be deleted with the appropriate Delete button (cf. Fig. 1.4).

- Colorbar from the Slice plot can be switched off with the Hide colorbar button (cf. Fig. 1.4).

When closing OpenDX, DO NOT save the visualization program. Doing this may affect the control panels. The visual program and its configuration file are made write-protected to avoid saving.